Start a new topic

Death squared bombs glitched out

A long long time ago, I played death squared with a friend on my laptop on steam, we got far, and then proceeded to get stuck at a specific level, and so we messed around with the setting instead of solving puzzles for fun, (I have beaten the game on my xbox since then, excellent game by the way) I didn't turn the bombs off since then.

Now there appears to have been some sort of update since then which made it so that you can only screw the game up once you've beaten it (dunno bout xbox), good idea! If only I didn't still have the bombs from prior enabled. Since then I couldn't really play the story mode normally, bombs falling from everywhere, and I appear to be unable to turn this setting off since that change.

Any ideas for what would help this? I even tried to delete my save buy failed somehow, but if I could keep my progress that'd be even better!

Hello there Yannick!

We're happy to hear that you enjoy the game!

The bombs is an advanced setting which is toggleable in the main games settings menu.

The game hasn't been updated for a while but by fiddling with these settings in your previous playthrough, something may have broken this.
The best course of action I could recommend would be doing a fresh installation of the game (which would mean deleting/uninstalling your files first).

This should delete/reset your game settings (including this broken button).


I pressed uninstall in steam, reinstalled it a second or so later, still know how many levels I completed and how fast and other save data, also deleted the steam cloud save and that didn't help either, still alarms going off and bombs falling on me in all levels, can't seem to find the setting to turn it off, believe it's the 'extra challenge' option, but that's locked to off until I beat the story mode, when I first turned those bombs on there was just an option called bombs I believe.
Sorry to bother you again.

Login or Signup to post a comment